import re
regex = re.compile(r"---\n[\s\S]+?(?=\n---|$)")
test_str = ("---\n"
"event: outgoing HTTP response\n"
"timestamp: 2021-10-06T08:15:28.212Z\n"
"remoteAddress: \"1.2.3.4\"\n"
"hostname: a.b.c.domain.com\n"
"statusCode: 200\n"
"headers:\n"
" content-length: 524\n"
" etc: ...\n"
"body: \"blabla (can be multiline and can contain anything)\"\n"
"---\n"
"event: outgoing HTTP response\n"
"timestamp: 2021-10-06T08:15:28.212Z\n"
"remoteAddress: \"1.2.3.4\"\n"
"hostname: a.b.c.different.com\n"
"statusCode: 200\n"
"headers:\n"
" content-length: 524\n"
" etc: ...\n"
"body: \"blabla (can be multiline and can contain anything)\"\n"
"---\n"
"event: outgoing HTTP response\n"
"timestamp: 2021-10-06T08:15:28.212Z\n"
"remoteAddress: \"1.2.3.4\"\n"
"hostname: 1.2.3.domain.com\n"
"statusCode: 200\n"
"headers:\n"
" content-length: 524\n"
" etc: ...\n"
"body: \"blabla (can be multiline and can contain anything)\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")