const regex = /news_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('news_', 'gm')
const str = `news_arts
news_offbeat
news_buss
news_features
news_latest
news_sport
news_topstories
news_politics
news_health
news_scitech
news_aust
news_world
news_rural
news_indigenous
news_enviro
news_morning_optin
news_alerts_optin
news_afternoon_optin
abc-splash-secondary_optin
abc-4kids_optin
4-corners_optin
mp_optin_interests
abc-science-updates_optin
abc-open_optin
702-abc-sydney_optin
btn_optin
abc-radio-national-late-night-live_optin
abc-rural_optin
abc-religion_optin
891-abc-adelaide_optin
abc-national-rural-news_optin
abc-tv-countdown-to-3_optin
dig_optin
abc-gardening_optin
abc-splash-stem_optin
abc-radio-national_optin
abcdailynewsemail_optin
abc-radio-national-music_optin
abc-tv-qanda_optin
abc-arts-culture_optin
abc-shop-news_optin
720-abc-perth_optin
abc-splash-primary_optin
abc-tv-switchedon_optin
666-abc-canberra_optin
abc-tv-iview_optin
abc-heywire_optin
triplej-unearthed_optin
774-abc-melbourne-books_optin
australia-plus-sports-lounge_optin
mp_optin_local
abc-radio-national-law-report_optin
abc-radio-national-saturday-extra_optin
australia-plus-china_optin
abc-radio-national-creative-audio-unit_optin
abc-jazz_optin
936-abc-hobart-wireless-news_optin
j-mail_optin
mp_optin_highlights
1057-abc-darwin_optin
612-abc-brisbane_optin
australia-plus_optin
774-abc-melbourne_optin
abctours_optin
abc-classic-fm_optin
abc-tv-compass_optin
abc-health-updates_optin
interest_children
interest_history
interest_sport
interest_music_alternative
interest_indigenous
interest_comedy
interest_music_easy
interest_attribute_downloads
interest_politics
interest_environment
interest_attribute_radio
interest_law
interest_documentary
interest_community
interest_music_country
interest_regional
interest_music_nostalgia
interest_music_jazz
interest_ghealth
interest_media
interest_books
interest_education
interest_games
interest_attribute_websites
interest_drama
interest_attribute_tv
interest_naturalhistory
interest_attribute_previews
interest_general_news
interest_cooking
interest_music_rock
interest_music_blues
interest_lifestyle
interest_entertainment
interest_travel
interest_music_classical
interest_youth
interest_attribute_shops
interest_business
interest_religion
interest_gardening
interest_science
interest_arts`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}