import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<protocol>\\w*)\\:\\/\\/(?<username>[\\w\\-]*@)?(?<domain>(?:(?<thld>[\\w\\-]*)\\.)?(?<sld>[\\w\\-]*)\\.(?<tld>[a-zA-Z]*))(?:\\:(?<port>\\d*))?";
final String string = "Course at https://udemy.com/path/to/course\n\n"
+ "Test at http://user@sample.com/path\n\n"
+ "Something ftp://domain.com:80/any";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}