$re = '/(?<protocol>\w*)\:\/\/(?<username>[\w\-]*@)?(?<domain>(?:(?<thld>[\w\-]*)\.)?(?<sld>[\w\-]*)\.(?<tld>[a-zA-Z]*))(?:\:(?<port>\d*))?/m';
$str = 'Course at https://udemy.com/path/to/course
Test at http://user@sample.com/path
Something ftp://domain.com:80/any';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);