$re = '/(?<=Gross Salary).+\s+(\d+$)/m';
$str = 'Gross Salary (A) 8000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);