#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "access_token=(\w+).*user_id=(\d+)"
Local $sString = "#access_token=699600f84569c1686d39fbd3a6511116b3cb6bbf5169d05c5be384355e381080ea033a7576e05efaf8&expires_in=86400&user_id=2693842"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")