re = /(?:\/|-|\+|\:|^|\(|\)| ) ?(\d+)/m
str = '4/13/2022 2:20:03 pm from our side a more detailed analysis4 +7 (495) 797-8700 77-8282'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result