// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\/|-|\+|\:|^|\(|\)| ) ?(\d+)").unwrap();
let string = "4/13/2022 2:20:03 pm from our side a more detailed analysis4 +7 (495) 797-8700 77-8282";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}