// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(:[a-zA-Z0-9.-]+) )?([a-zA-Z]+|[0-9]+)((?: [a-zA-Z0-9]+)*(?: :.+)?)$").unwrap();
let string = ":aaa 001 haaaa heu hii hoooo huuu
:aa NICK allo pateee :hello jhsdfhu
NOTICE :allo, les potes comment va ?
AAA a b c d e f :allo, ok !&*8? -_=% :okok";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}