import Foundation
let pattern = #"^(?:(:[a-zA-Z0-9.-]+) )?([a-zA-Z]+|[0-9]+)((?: [a-zA-Z0-9]+)*(?: :.+)?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
:aaa 001 haaaa heu hii hoooo huuu
:aa NICK allo pateee :hello jhsdfhu
NOTICE :allo, les potes comment va ?
AAA a b c d e f :allo, ok !&*8? -_=% :okok
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)