using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/?script[^>]*>";
string input = @"<script>
</script>
<script >
<script type=""text/javascript"">
<script type=""text/javascript"" >
<script 'wut'>
<Script>
<SCRIPT type=""text/javascript"">
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}