re = /<\/?script[^>]*>/i
str = '<script>
</script>
<script >
<script type="text/javascript">
<script type="text/javascript" >
<script \'wut\'>
<Script>
<SCRIPT type="text/javascript">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end