re = /<a\s[^<>]*>([^<>]*)<\/a>/m
str = '<a href="/?genre=Action">Actions</a> <a href="/?genre=Sci-Fi">Sci-Fi</a>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result