$re = '/[^a-zA-Z ]/';
$str = 'ABC(D E+FGH?/IJK LMN~OP';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;