#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^class ([\w]+)\([^)]+\):"
Local $sString = "class foo1(object):" & @CRLF & _
" bar1()" & @CRLF & _
"" & @CRLF & _
"class foo2(object):" & @CRLF & _
" bar2()" & @CRLF & _
"" & @CRLF & _
"class foo3(object):" & @CRLF & _
" bar3()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")