$re = '/<(?:(?<closeTag>\/)?(?<tagName>[A-Za-z]+)(?<tagAttributes>(\s*(?:\w+)\s*=\s*(["|\']).*?\5)*)\s*(?<selfClosingTag>\/)?>)/m';
$str = 'fafas<a href="test">fasfsafa</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);