package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w.-]+ ?(?:@|\[?at]?) ?[\w.-]+(?: ?\[?dot]? ?[\w.-]+)?`)
var str = `info@example.com
info [at] example [dot] com
info at example.com info
info at example dot com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}