re = /[\w.-]+ ?(?:@|\[?at]?) ?[\w.-]+(?: ?\[?dot]? ?[\w.-]+)?/
str = 'info@example.com
info [at] example [dot] com
info at example.com info
info at example dot com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end