import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(sites\\/?)?(.*)$";
final String string = "/sites/global\n"
+ "/page/file.ext\n"
+ "/sites/other\n"
+ "/page.ext\n"
+ "/intranet/global\n"
+ "http://intranet/global";
final String subst = "/sites/\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}