using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-\s+)(lat)(.*)(\n\s*)(long)";
string substitution = @"$1$5$3$4$2";
string input = @"- lat: ""-82.645672""
long: '44.941747'
title: ""Item 1""
- lat: ""-82.645744""
long: '44.940731'
title: ""Item 2""
- lat: ""-82.645744""
long: '44.940731'
title: ""Item 3""
- lat: ""-82.646599""
long: '44.941441'
title: ""Item 4""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}