#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*([os])(?:.*\1){1})(?!.*([p])(?:.*\2){2})[pos]+$"
Local $sString = "pop" & @CRLF & _
"sop" & @CRLF & _
"ps" & @CRLF & _
"pops" & @CRLF & _
"poop" & @CRLF & _
"p" & @CRLF & _
"pp" & @CRLF & _
"ppp" & @CRLF & _
"pppp" & @CRLF & _
"o" & @CRLF & _
"oo" & @CRLF & _
"s" & @CRLF & _
"ss" & @CRLF & _
"popp" & @CRLF & _
"ppos"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")