re = /^(?!.*([os])(?:.*\1){1})(?!.*([p])(?:.*\2){2})[pos]+$/m
str = 'pop
sop
ps
pops
poop
p
pp
ppp
pppp
o
oo
s
ss
popp
ppos'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end