import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\w)\\w+(?=\\w{2}$)|(?<=^\\w)\\w+";
final String string = "Иванов Иван Иванович\n"
+ "Ли Иван Иванович\n"
+ "Петров Пётр Петрович";
final String subst = "***";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}