use strict;
my $str = 'Иванов Иван Иванович
Ли Иван Иванович
Петров Пётр Петрович';
my $regex = qr/(?<=\w)\w+(?=\w{2}$)|(?<=^\w)\w+/mup;
my $subst = '***';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";