# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(((pro\b)(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))?(( +[^)])([^ )]*))? *|(.*?))\)/(${2}\U${4}\L${5}\U${7}\L${8}\U${10}\L${11}\U${13}\L${14}\U${16}\L${17}\U${19}\L${20}\L${21})/gm;t' <<< "4377631753733131 (pro alber con tr33)
886uhghsdfdsfh (pro cios tui tr32)
rtyqrey 6y46457 6372576 (Flrt ghnap tsr)
537657QQRFytyvg (flipzz Reyhdf frfg33)
4377631753733131 (pro alber con tr33 alber con tr33) (flipzz Reyhdf frfg33) (Foo pro bar pro cios tui tr32)
537657QQRFytyvg (pro foo ))
I would like all words after \"pro\" to be capitalized. If \"pro\" is not present, all words in the brackets must be lowercase, for have :
4377631753733131 (pro Alber Con Tr33)
886uhghsdfdsfh (pro Cios Tui Tr32)
rtyqrey 6y46457 6372576 (flrt ghnap tsr)
537657QQRFytyvg (flipzz reyhdf frfg33)"