package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9]*?([0-9]+)$`)
var str = `a123
a2a123
123
abc
123abc
()123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}