$re = '/\((-.*?)\)/';
$str = '2016/99/99 12:00:0.999 2 1 (-499) Cannot open the message store with error code';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);