const regex = /.*?([\w-]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?([\\w-]+)$', 'gm')
const str = `https://www.youtube.com/watch?v=K1CScQOj1dA
https://youtu.be/wIJ1sFrgMds
IISzG-sPUuo
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);