$re = '/(?<=Betrag:)(([\s]*)\d{1,8}([\.,]\d{2})){2}/';
$str = 'Betrag: 100,00 150,00 350,00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);