const regex = new RegExp('(?<=/os/).*(?=[?])', 'm')
const str = `/maximo/oslc/os/mxapiwodetail?lean=1&oslc.select=*&savedQuery=cxmobile_4abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}