const regex = /\\-(?=\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\-(?=\\S)', 'g')
const str = `car \\- https://youtu.be/iOA7NUI\\-9Xhw video\\-one \\-`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);