using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\~\![A-Za-z]+\ start(?:(?:(?:\(|,)\ ?[\w]+)*?\))\:\{([\S\s]+?)(?:(?<!\\)\}\:end)";
string input = @"~!data start(f1, f2, f3):{
abc '\}:end'a
}:end
~!data start(f1, f2, f3):{
abc '\}:end'a
}:end";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}