const regex = /<td>((?:(?!<\/td>).)*)<\/td><td>(\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)<\/td>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td>((?:(?!<\\\/td>).)*)<\\\/td><td>(\\b\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\b)<\\\/td>', 'g')
const str = `<td>over079</td><td>37.123.86.116</td></tr><tr><td>1346968</td><td>rektheace</td><td></td></tr><tr><td>1346967</td><td>rektheace</td><td>173.245.67.214</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}