import re
regex = re.compile(r"(\d+)d (\d+)h (\d+)(?:min|m) (\d+)s")
test_str = "5d 23h 40min 56s"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")