// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{3}\.\d+\.\d+\.\d+").unwrap();
let string = "The following is an ip address 127.0.0.1
Use the ip 192.168.33.21 to reach home.
188.25.125.105
127.0.1.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}