use strict;
my $str = '/
beta/alpha/';
my $regex = qr~([^/])/$~mp;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";