using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\W?\d*?\W*?(?<area>\d{3})\W*?(?<group1>\d{3})\W*?(?<group2>\d{4})\W*?$";
string substitution = @"Phone Number: (\{area})-\{group1}-\{group2}";
string input = @"6109410561
(484) 844.0221
484-433-8115
484 433 7972
610.715.6728
+16109410561
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}