import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\W?\\d*?\\W*?(?<area>\\d{3})\\W*?(?<group1>\\d{3})\\W*?(?<group2>\\d{4})\\W*?$";
final String string = "6109410561\n"
+ "(484) 844.0221\n"
+ "484-433-8115\n"
+ "484 433 7972\n"
+ "610.715.6728\n"
+ "+16109410561\n";
final String subst = "Phone Number: (\\{area})-\\{group1}-\\{group2}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}