# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\W?\d*?\W*?(?<area>\d{3})\W*?(?<group1>\d{3})\W*?(?<group2>\d{4})\W*?$"
test_str = ("6109410561\n"
"(484) 844.0221\n"
"484-433-8115\n"
"484 433 7972\n"
"610.715.6728\n"
"+16109410561\n")
subst = "Phone Number: (\\{area})-\\{group1}-\\{group2}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.