// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\W?\d*?\W*?(?<area>\d{3})\W*?(?<group1>\d{3})\W*?(?<group2>\d{4})\W*?$").unwrap();
let string = "6109410561
(484) 844.0221
484-433-8115
484 433 7972
610.715.6728
+16109410561
";
let substitution = "Phone Number: (\\{area})-\\{group1}-\\{group2}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}