package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(BETWEEN .* AND .*[?!\s])`)
var str = `testing BETWEEN THIS AND ? ending`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}