import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]:.*\\.\\w+";
final String string = "\"msqlsum81pv 0 0 25 25 25 2 -sn D:\\\\workdir\\\\PV 81\\\\config\\\\sum81pv.pwf -C 5000\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}