$re = '/[A-Z]:.*\.\w+/';
$str = '"msqlsum81pv 0 0 25 25 25 2 -sn D:\\\\workdir\\\\PV 81\\\\config\\\\sum81pv.pwf -C 5000"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;