// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xsm) # free-spacing mode, DOTALL, multi-line
(?=.*?blue) # if blue isn't there, fail without delay
###### Recursive Section ######
# This section aims to balance empty lines with digits, i.e.
# emptyLine,emptyLine,emptyLine ... ~1~2~3
# The last digit block is captured to Group 2, e.g. ~3
(?= # lookahead
( # Group 1
(?: # skip one line that doesn't contain blue
^ # start of line
(?:(?!blue)[^\r\n])* # zero or more chars not followed by blue
(?:\r?\n) # newline
)
(?:(?1)|[^~]+) # recurse Group 1 OR match all non-tilde chars
(~\d+) # match a sequence of digits
)? # End Group 1
) # End lookahead.
# Group 2, if set, now contains the number of lines skipped
.*? # lazily match chars up to...
blue # match blue
.*? # lazily match chars up to...
(?(2)\2) # if Group 2 is set, match Group 2
~ # Match the next tilde
\K # drop what was matched so far
\d+ # match the next digits: this is the match
").unwrap();
let string = "Paint it white
Paint it black
Why not blue?
Or red or brown?
~1~2~3~4~5~6~7~8~9~10";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}