# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{{[^}]+?(?:,?img:([^,}]+))?(?:,?alt:([^,}]+),)?(?:,?ht:(\d+))?(?:,?wd:(\d+))?(?:,?align:(\w+))?}}/<img src="www.abc.com\/media\/images\/$1" alt="$2" width="$3" height="$4" align="$5">/ig;t' <<< "juices vegetables including {{smartpro=img:hippo-1.jpg,alt:Hippocrates,ht:217,wd:247,align:left}} wheatgrass, leafy greens, parsley, aloe vera & other herbs"