use strict;
my $str = 'juices vegetables including {{smartpro=img:hippo-1.jpg,alt:Hippocrates,ht:217,wd:247,align:left}} wheatgrass, leafy greens, parsley, aloe vera & other herbs';
my $regex = qr~{{[^}]+?(?:,?img:([^,}]+))?(?:,?alt:([^,}]+),)?(?:,?ht:(\d+))?(?:,?wd:(\d+))?(?:,?align:(\w+))?}}~ip;
my $subst = '<img src="www.abc.com/media/images/$1" alt="$2" width="$3" height="$4" align="$5">';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";