$re = '/([\'\"])(?:\\\\.|.)*?\1/';
$str = '"Hello", is it \'me you\\\'re looking for\'?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);