using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('<dox>\n|'\s*[\S \t]*)";
string input = @"'test begin...
'<dox>
' <member type=""Public Sub"" name=""Increment"" return=""void"">
' <param type=""Integer"" name=""nBase"" out=""true"" />
' <param type=""Integer"" name=""nStep"" out=""false"" />
' <purpose>
' purpose here...
' </purpose>
' </member>
' <member ... />
'</dox>
'other comments here...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}