# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"('<dox>\n|'\s*[\S \t]*)"
test_str = ("'test begin...\n"
"'<dox>\n"
"' <member type=\"Public Sub\" name=\"Increment\" return=\"void\">\n"
"' <param type=\"Integer\" name=\"nBase\" out=\"true\" />\n"
"' <param type=\"Integer\" name=\"nStep\" out=\"false\" />\n"
"' <purpose>\n"
"' purpose here...\n"
"' </purpose>\n"
"' </member>\n"
"' <member ... />\n"
"'</dox>\n"
"'other comments here...")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.