re = /('<dox>\n|'\s*[\S \t]*)/
str = '\'test begin...
\'<dox>
\' <member type="Public Sub" name="Increment" return="void">
\' <param type="Integer" name="nBase" out="true" />
\' <param type="Integer" name="nStep" out="false" />
\' <purpose>
\' purpose here...
\' </purpose>
\' </member>
\' <member ... />
\'</dox>
\'other comments here...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end